1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/usr/bin/dpkg error in Kali Linux 1.1.0

Discussion in 'How-To's' started by MrRama049, Feb 8, 2017.

  1. MrRama049

    MrRama049 New Member

    Joined:
    Feb 8, 2017
    Messages:
    1
    Likes Received:
    0
    Hello friends! I'm getting this problem in my Kali Linux 1.1.0 distribution (codename:moto) which I'm running on my android phone:-
    root@localhost:~# apt-get install abe
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    abe-data libasyncns0 libcaca0 libdirectfb-1.2-9 libflac8 libjson0 libmikmod2
    libpulse0 libsdl-mixer1.2 libsdl1.2debian libsndfile1 libts-0.0-0
    libvorbisenc2 tsconf
    Suggested packages:
    pulseaudio-esound-compat oss-compat pulseaudio
    The following NEW packages will be installed:
    abe abe-data libasyncns0 libcaca0 libdirectfb-1.2-9 libflac8 libjson0
    libmikmod2 libpulse0 libsdl-mixer1.2 libsdl1.2debian libsndfile1 libts-0.0-0
    libvorbisenc2 tsconf
    0 upgraded, 15 newly installed, 0 to remove and 2 not upgraded.
    3 not fully installed or removed.
    Need to get 5535 kB of archives.
    After this operation, 10.9 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://old.kali.org/kali/ moto/main libasyncns0 armhf 0.8-4+b1 [12.1 kB]
    Get:2 http://old.kali.org/kali/ moto/main libcaca0 armhf 0.99.beta18-1 [377 kB]
    Get:3 http://old.kali.org/kali/ moto/main tsconf all 1.0-11 [13.4 kB]
    Get:4 http://old.kali.org/kali/ moto/main libts-0.0-0 armhf 1.0-11 [29.9 kB]
    Get:5 http://old.kali.org/kali/ moto/main libdirectfb-1.2-9 armhf 1.2.10.0-5 [1059 kB]
    Get:6 http://old.kali.org/kali/ moto/main libflac8 armhf 1.2.1-6+deb7u1 [137 kB]
    Get:7 http://old.kali.org/kali/ moto/main libmikmod2 armhf 3.1.12-5 [151 kB]
    Get:8 http://old.kali.org/kali/ moto/main libjson0 armhf 0.10-1.2 [20.9 kB]
    Get:9 http://old.kali.org/kali/ moto/main libvorbisenc2 armhf 1.3.2-1.3 [121 kB]
    Get:10 http://old.kali.org/kali/ moto/main libsndfile1 armhf 1.0.25-5 [234 kB]
    Get:11 http://old.kali.org/kali/ moto/main libpulse0 armhf 2.0-6.1 [204 kB]
    Get:12 http://old.kali.org/kali/ moto/main libsdl1.2debian armhf 1.2.15-5 [191 kB]
    Get:13 http://old.kali.org/kali/ moto/main libsdl-mixer1.2 armhf 1.2.12-3 [84.1 kB]
    Get:14 http://old.kali.org/kali/ moto/main abe-data all 1.1+dfsg-1 [2862 kB]
    Get:15 http://old.kali.org/kali/ moto/main abe armhf 1.1+dfsg-1 [37.3 kB]
    Fetched 5535 kB in 1min 31s (60.8 kB/s)
    Selecting previously unselected package libasyncns0:armhf.
    (Reading database ... 110082 files and directories currently installed.)
    Unpacking libasyncns0:armhf (from .../libasyncns0_0.8-4+b1_armhf.deb) ...
    Selecting previously unselected package libcaca0:armhf.
    Unpacking libcaca0:armhf (from .../libcaca0_0.99.beta18-1_armhf.deb) ...
    Selecting previously unselected package tsconf.
    Unpacking tsconf (from .../archives/tsconf_1.0-11_all.deb) ...
    Selecting previously unselected package libts-0.0-0:armhf.
    Unpacking libts-0.0-0:armhf (from .../libts-0.0-0_1.0-11_armhf.deb) ...
    Selecting previously unselected package libdirectfb-1.2-9:armhf.
    Unpacking libdirectfb-1.2-9:armhf (from .../libdirectfb-1.2-9_1.2.10.0-5_armhf.deb) ...
    Selecting previously unselected package libflac8:armhf.
    Unpacking libflac8:armhf (from .../libflac8_1.2.1-6+deb7u1_armhf.deb) ...
    Selecting previously unselected package libmikmod2:armhf.
    Unpacking libmikmod2:armhf (from .../libmikmod2_3.1.12-5_armhf.deb) ...
    Selecting previously unselected package libjson0:armhf.
    Unpacking libjson0:armhf (from .../libjson0_0.10-1.2_armhf.deb) ...
    Selecting previously unselected package libvorbisenc2:armhf.
    Unpacking libvorbisenc2:armhf (from .../libvorbisenc2_1.3.2-1.3_armhf.deb) ...
    Selecting previously unselected package libsndfile1:armhf.
    Unpacking libsndfile1:armhf (from .../libsndfile1_1.0.25-5_armhf.deb) ...
    Selecting previously unselected package libpulse0:armhf.
    Unpacking libpulse0:armhf (from .../libpulse0_2.0-6.1_armhf.deb) ...
    Selecting previously unselected package libsdl1.2debian:armhf.
    Unpacking libsdl1.2debian:armhf (from .../libsdl1.2debian_1.2.15-5_armhf.deb) ...
    Selecting previously unselected package libsdl-mixer1.2:armhf.
    Unpacking libsdl-mixer1.2:armhf (from .../libsdl-mixer1.2_1.2.12-3_armhf.deb) ...
    Selecting previously unselected package abe-data.
    Unpacking abe-data (from .../abe-data_1.1+dfsg-1_all.deb) ...
    Selecting previously unselected package abe.
    Unpacking abe (from .../abe_1.1+dfsg-1_armhf.deb) ...
    Processing triggers for man-db ...
    Processing triggers for desktop-file-utils ...
    Processing triggers for menu ...
    Setting up postgresql-common (134wheezy4) ...
    supported_versions: WARNING! Unknown distribution: Kali
    Please submit this as a bug report to your distribution.
    /bin/df: Warning: cannot read table of mounted file systems: No such file or directory
    insserv: warning: current start runlevel(s) (empty) of script `postgresql' overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `postgresql' overrides LSB defaults (0 1 6).
    [....] Starting PostgreSQL 9.1 database server: main[....] The PostgreSQL server failed to start. Please check the log output: 2017-02-07 18:41:11 UTC LOG: could not create IPv4 socket: Permission denied 2017-02-07 18:41:11 UTC WARNING: could not create listen socket for "localhost" 2017-02-07 18:41:11 UTC FATAL: could[FAILcreate any TCP/IP sockets ... failed!
    failed!
    invoke-rc.d: initscript postgresql, action "start" failed.
    dpkg: error processing postgresql-common (--configure):
    subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of postgresql-9.1:
    postgresql-9.1 depends on postgresql-common (>= 115~); however:
    Package postgresql-common is not configured yet.

    dpkg: error processing postgresql-9.1 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of postgresql:
    postgresql depends on postgresql-9.1; however:
    Package postgresql-9.1 is not configured yet.

    dpkg: error processing postgresql (--configure):
    dependency problems - leaving unconfigured
    Setting up libasyncns0:armhf (0.8-4+b1) ...
    Setting up libcaca0:armhf (0.99.beta18-1) ...
    Setting up tsconf (1.0-11) ...
    Setting up libts-0.0-0:armhf (1.0-11) ...
    Setting up libdirectfb-1.2-9:armhf (1.2.10.0-5) ...
    Setting up libflac8:armhf (1.2.1-6+deb7u1) ...
    Setting up libmikmod2:armhf (3.1.12-5) ...
    Setting up libjson0:armhf (0.10-1.2) ...
    Setting up libvorbisenc2:armhf (1.3.2-1.3) ...
    Setting up libsndfile1:armhf (1.0.25-5) ...
    Setting up libpulse0:armhf (2.0-6.1) ...
    Setting up libsdl1.2debian:armhf (1.2.15-5) ...
    Setting up libsdl-mixer1.2:armhf (1.2.12-3) ...
    Setting up abe-data (1.1+dfsg-1) ...
    Setting up abe (1.1+dfsg-1) ...
    Processing triggers for menu ...
    Errors were encountered while processing:
    postgresql-common
    postgresql-9.1
    postgresql
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    So whenever I try to install any application it ends up showing this:- E: Sub-process /usr/bin/dpkg returned an error code (1)
    Can anyone help me in solving this issue? I'm new to Kali Linux. I really appreciate any help.
     
    #1
  2. DarkSolo

    DarkSolo Staff Member

    Joined:
    Mar 14, 2013
    Messages:
    205
    Likes Received:
    49
    try launching postgresql manually or reconfigure it.
    one question: why not kali Sana?
     
    #2
  3. global2016

    global2016 New Member

    Joined:
    Mar 16, 2018
    Messages:
    2
    Likes Received:
    0
  4. bokepfr

    bokepfr Member

    Joined:
    Mar 14, 2018
    Messages:
    128
    Likes Received:
    0
    terima kasih atas postingan anda
     
    #4

Share This Page